Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 01, 2025 - 16:00 CEST
Scheduled
On Monday 2025-09-01 4:00PM CET we will upgrade the ISO Online Standards Development (OSD) platform to version 5.0. Application downtime will be 1hr. We apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Aug 19, 2025 - 21:36 CEST
This scheduled maintenance affected: Development of standards (ISO Online Standards Development (OSD)).