Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 09, 2024 - 07:30 CEST
Scheduled
A technical update will be carried out on the Documents application impacting ISO, CEN and National working areas. Application downtime is 10 to 30 minutes.
Such technical upgrades are carried out on a regular basis because they enhance our efficiency, security, and performance, and ensure you can operate more effectively in an evolving digital landscape.
Posted Jul 08, 2024 - 13:35 CEST
This scheduled maintenance affected: Development of standards (ISO Documents).