Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2025 - 14:00 CEST
Scheduled
A technical update will be carried out on the Documents application impacting ISO, CEN and National working areas. Application downtime is 30 minutes to 1 hour.
Such technical upgrades are carried out on a regular basis because they enhance our efficiency, security, and performance, and ensure you can operate more effectively in an evolving digital landscape.
Posted Jun 13, 2025 - 10:03 CEST
This scheduled maintenance affected: Development of standards (ISO Documents).