Verification is currently underway for the maintenance items.
Posted Sep 09, 2025 - 15:45 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2025 - 08:00 CEST
Scheduled
On September 9, between 08:00 and 17:00 CEST, we will be performing maintenance on our systems. While no significant disruptions are expected, there may be temporary slowdowns or interruptions across all services.
If you encounter any delays or issues, please try again after a few minutes. We apologize for any inconvenience this may cause. Updates will be provided here as needed.