Major incident on our network impacting all our services

Incident Report for ISO

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 11:25 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2025 - 11:07 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 10, 2025 - 10:36 CEST

Update

We are continuing to investigate this issue.
Posted Jul 10, 2025 - 10:07 CEST

Investigating

We are currently experiencing a significant network disruption following a recent maintenance operation. Our technical teams are actively investigating the issue and working diligently to restore full service as quickly as possible.

We sincerely apologize for the inconvenience and appreciate your patience.
Posted Jul 10, 2025 - 10:07 CEST
This incident affected: Marketing and Sales (ISO Standards Maintenance Portal, ISO Online Browsing Platform (OBP), ISO Webstore - Authentication, ISO Webstore - Basket, Product Item Webservice check, ISO Webstore - Payment integration [EXTERNAL]), Application Programming Interfaces (APIs) (ISO APIs for Projects, Publications, Committee Working Documents and Ballots, ISO APIs for Identities and Roles, ISO APIs for Publishing), Web Conferencing (Zoom Meetings [EXTERNAL], Zoom Meeting Telephony Services [EXTERNAL]), Development of standards (ISO Documents, ISO Projects, ISO Meetings, ISO Ballots, ISO Online Standards Development (OSD), ISO Post-Voting Decision & eForm4, Global Directory, ISO Portal), Services provided to members and partners (PDF services), Authentication and authorization (Single Sign-On), Communication (ISO Connect, iso.org, ISO Technical Committees websites), and Access to ISO deliverables (incl. standards and publications) (ISO Content Exchange (ICE) repository).