Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 22, 2026 - 10:03 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 22, 2026 - 07:00 CEST
Scheduled
We will be upgrading our Jahia platform to the latest stable version on Monday, June 22nd. This important update serves a dual purpose: ensuring our systems meet the highest security standards, and providing our content editors with the newest features and functionalities.
To perform this upgrade safely, a complete server shutdown is required. As a result, ISO.org and ISO Technical Committees websites will be entirely unavailable between 7:00 AM and 9:00 AM. Normal access and services are expected to resume promptly at 9:00 AM.
Thank you for your understanding and cooperation as we work to improve our digital platforms.
Posted Jun 15, 2026 - 17:54 CEST
This scheduled maintenance affected: Communication (iso.org, ISO Technical Committees websites).