Meetings Down
Incident Report for ISO
Resolved
This incident has been resolved.
Posted Jul 22, 2020 - 15:24 CEST
Monitoring
Issue is now fixed, we are monitoring closely the situation.
Posted Jul 22, 2020 - 14:32 CEST
Investigating
We are currently investigation an issue that impact the following applications.
Posted Jul 22, 2020 - 14:25 CEST
This incident affected: Development of standards (ISO Meetings).