ISO Projects unstable
Incident Report for ISO
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 16:57 CEST
Monitoring
The situation is now stable, we are still monitoring it closely.
Posted Jul 28, 2020 - 16:25 CEST
Investigating
We are currently facing intermittent issues with Projects.
We are working to fix the issue.
Posted Jul 28, 2020 - 11:14 CEST
This incident affected: Development of standards (ISO Projects).