www.iso.org unavailable

Incident Report for ISO

Resolved

The incident has been resolved. iso.org and committees' websites are back to normal.
Posted Dec 26, 2024 - 18:41 CET

Update

We are continuing investigating the issue with our service provider. Only iso.org and committees' websites are impacted. All other services are available.
Posted Dec 26, 2024 - 09:46 CET

Investigating

We are currently investigating the issue.
Posted Dec 25, 2024 - 17:46 CET
This incident affected: Communication (iso.org).